All Assets
Sci-fi Design Kit
Sci-FiBr2 ArtsWorks
Unfortunately, Sci-fi Design Kit is no longer available.
This package has been deprecated from the Asset Store. This means that new purchases of the package are not allowed and that only users who already purchased or downloaded the package before it was deprecated, are allowed to download it.
In most cases, package deprecation happens because the publisher is unable or unwilling to support the package anymore. We suggest looking for alternative packages or contacting the publisher directly.
If you've already purchased it and need to download a copy, you can do so here.